/ networking

Intro to GNS3 and Layer 3 Routing (OSPF)

When it comes to network emulation GNS3 is as close as you can get. Packet Tracer is a great alternative however some commands do not function as intended or are completely lacking. GNS3 is a network simulation program that uses actual Cisco IOS.

GNS3 works by using a virtual machine as the foundation of the simulation. In fact you need a hypervisor like VMWare Fusion/Workstation or Oracle's Virtualbox. The hypervisor will do the underlying magic and emulate the networking equipment we need to simulate OSPF routing.

What you will need:

  1. Hypervisor
  2. GNS3 (Download here)

3. Cisco IOS image (download Cisco IOS here)

4. GNS3 Virtual Machine (download here)

5. Tons of patience

Installing GNS3

Before proceeding with this step, please make sure your hypervisor is ready to go and you have imported the GNS3 VM to your hypervisor of choice. (In this example I'll be using VMWare Fusion.)

By now you should have the GNS3 vm downloaded, if not see #4 above. Alright lets begin the import process. Fire up your hypervisor and import the OVF file.

After the import, fire up your GNS3 vm and you should see something like below.

Now lets install the actual GNS3 software. The install process is fairly straightforward - just click to continue or rather drag to the application folder.

Once the install is complete, launch GNS3! You will be greeted with a screen to create a new project. Name this project "OSPF":

To do create the OSPF lab we will need three routers. However first we need to import the Cisco IOS images so that we can play with our routers.

Click on the router icon on the top left, then click on "New appliance template".

In the next window that appears, select "Add an IOS router using a real IOS image (supported by Dynamips)".

Following that select "Run this IOS router on my local computer".

In the next screen it will ask for the location of the IOS image. I will be using c3745-advipservicesk9-mz.124-25d.image as the image of my router, this is the same IOS images used on Cisco 3745 routers. Once you have selected your IOS image, click next and accept the defaults. You can choose to enable different modules, but for this tutorial I will just use the default fastethernet ports.

Click "Next" until you get to the Idle-PC page. On this page click on the "Idle-PC finder". This step is important to prevent the GNS3 from using 100% of your CPU's cores. Once it finds an idle-pc value, click on "Finish".

Now search for the router and drag it to the middle window.

Click on the green play button on the top to startup the routers. To bring up the console session click on the icon to the left of the green play button. This will trigger your terminal to open up two sessions one for each router.

Once the console session is up and running enter the show ver command and you should see something like below:

R3#show ver
Cisco IOS Software, 3700 Software (C3745-ADVIPSERVICESK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 18-Aug-10 08:18 by prod_rel_team

ROM: ROMMON Emulation Microcode
ROM: 3700 Software (C3745-ADVIPSERVICESK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)

R3 uptime is 5 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"

............................................................

Looking good! Now grab another router, since we need three routers for this OSPF tutorial. Once you have the third router, connect them together by clicking on the "Add link" button and then click on one of your routers and select an empty interface. Empty interfaces are marked in red.

Configuring OSPF

What is OSPF? OSPF is a routing protocol called Open Shortest Path First, it's an open protocol which means it's supported by other vendors not just Cisco unlike EIGRP. OSPF utilizes link states routing to determine the most effective path to get to a destination. It also has self healing capabilities, which means it can find another path to device if the first path is down for any reason. Great for redundancy! With OSPF every router in the topology will know about the networks and subnets behind each router. So each router will have the same info as each other. This is done through the magic of link states specifically the link state advertisements (LSA).

Without anymore delay let's get to the good stuff and configure the routers. Open up a terminal session to R1. Create three loopback interfaces and assign it ip addresses. To do that you will need to go into configuration mode and activate the loopback interfaces. The loopback interfaces will act as our subnets behind the router. I will refer to this diagram when setting up my topology.

R1#conf t 
R1(config)#int lo0
R1(config-if)#ip address 10.0.0.1 255.255.255.0

You will repeat the steps for the other two loopback interfaces (lo1 and lo2), however assign them IP addresses on a different /24 subnet. What you should get is something like this:

R1#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down
FastEthernet0/1            unassigned      YES unset  administratively down down
Loopback0                  10.0.0.1        YES manual up                    up
Loopback1                  10.0.2.1        YES manual up                    up
Loopback2                  10.0.3.1        YES manual up                    up









R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
C       10.0.2.0 is directly connected, Loopback1
C       10.0.3.0 is directly connected, Loopback2
C       10.0.0.0 is directly connected, Loopback0

As you can see in the show ip route command there are three /24 networks summarized in a 10.0.0.0 /24 subnet.

Before we go any further, I'll enable CDP so that we can simulate how an actual network engineer will go about drawing a mental picture of how devices are connected. To do this, go into configuration mode select an interface int fa0/0 and enter the command cdp enable. I will then assign the interface an IP address of 10.100.0.1 /24. ip address 10.100.0.1 255.255.255.0 and then no shutdown to startup the interface. While I'm still on R1 I'll also give it's fa0/1 interface an IP address of 10.100.1.1 /24 and enable cdp on it's interface.

Now I'll head over to R2 and configure it's fa0/0 interface to communicate with R1. Similar to the steps in R1, I'll change modes into configuration terminal conf t and select fa0/0 since according to our topology map it's connected to R1. I'll give this an IP address that will fall inside of the 10.100.1.0 /24 subnet. (I assigned it 10.100.1.2)

Once R2's fa0/0 is configured I'll check cdp neighbors. show cdp neighbors You should see something like this:

R2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R1               Fas 0/0            120        R S I      3745      Fas 0/1

R1 should show up in the list. It will list info such as the local interface it's connected to on R2, the device platform and the port R2 is connected to on R1. Also if you ping R1's IP address from R2, it should be successful.

R2#ping 10.100.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/60/64 ms

Next step is to configure the loopback interfaces of R2. I will be using the IP scheme below:

lo0 - 10.0.4.0 /24

l01 - 10.0.5.0 /24

lo2 - 10.0.6.0 /24

And since we're already on R2, I'll configure fa0/1 with an IP address of 10.100.2.1 /24. You should have something similar to mine:

R2#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.100.1.2      YES manual up                    up
FastEthernet0/1            10.100.2.1      YES manual up                    up
Loopback0                  10.0.4.1        YES manual up                    up
Loopback1                  10.0.5.1        YES manual up                    up
Loopback2                  10.0.6.1        YES manual up                    up








R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
C       10.0.6.0 is directly connected, Loopback2
C       10.0.4.0 is directly connected, Loopback0
C       10.0.5.0 is directly connected, Loopback1
C       10.100.2.0 is directly connected, FastEthernet0/1
C       10.100.1.0 is directly connected, FastEthernet0/0

Lastly configure R3 with the following loopbacks:

lo0 - 10.0.7.0 /24

lo1 - 10.0.8.0 /24

lo2 - 10.0.9.0 /24

And interface IP addresses:

fa0/1 - 10.100.2.2 /24

fa0/0 - 10.100.0.2 /24

What you should have will look similar to mine:

R3#show ip int br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            10.100.0.2      YES manual up                    up
FastEthernet0/1            10.100.2.2      YES manual up                    up
Loopback0                  10.0.7.1        YES manual up                    up
Loopback1                  10.0.8.1        YES manual up                    up
Loopback2                  10.0.9.1        YES manual up                    up






R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
C       10.0.8.0 is directly connected, Loopback1
C       10.0.9.0 is directly connected, Loopback2
C       10.0.7.0 is directly connected, Loopback0
C       10.100.2.0 is directly connected, FastEthernet0/1
C       10.100.0.0 is directly connected, FastEthernet0/0





R3#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R2               Fas 0/1            149        R S I      3745      Fas 0/1
R1               Fas 0/0            177        R S I      3745      Fas 0/0

Don't forget to save the configurations to memory with wr mem while in priviledge exec mode!

Hop back into R1 and try to ping a loopback interface on R3... hmm nothing!

R1#ping 10.0.7.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.7.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Let's double check the routes and see what networks R1 knows about. show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 5 subnets
C       10.0.2.0 is directly connected, Loopback1
C       10.0.3.0 is directly connected, Loopback2
C       10.0.0.0 is directly connected, Loopback0
C       10.100.0.0 is directly connected, FastEthernet0/0
C       10.100.1.0 is directly connected, FastEthernet0/1

As you can see R1 knows about networks that are directly connected to it. It has no knowledge about the subnets on R2's and R3's loopback interfaces.

Time to hop back into R1 and get it ready for OSPF routing. Head into configuration mode conf t, and we'll enter the router configuration mode by entering router ospf 1. Notice the prompt change below. Also I'll set R1 as the designated router by giving it a router-ID of 9.9.9.9

R1(config)#router ospf 1
R1(config-router)#
R1(config-router)#router-id 9.9.9.9

Now I'll instruct R1 to include the subnets on it's fastethernet interfaces in its link state advertisements with the area ID of 0.network <IP ADDRESS> <WILDCARD> area <0-10>

R1(config-router)#network 10.100.0.0 0.0.0.255 area 0
R1(config-router)#network 10.100.1.0 0.0.0.255 area 0

Also I'll include the subnets for the loopback interfaces.

R1(config-router)#network 10.0.0.0 0.0.0.255 area 1
R1(config-router)#network 10.0.2.0 0.0.0.255 area 1
R1(config-router)#network 10.0.3.0 0.0.0.255 area 1

Cool, let hop over to R2 and configure it. Notice when you advertise the 10.100.1.0 subnet you get an adjacency message! This is good, we want to see adjacency being formed.

R2(config)#router ospf 1
R2(config-router)#router-id 8.8.8.8
R2(config-router)#network 10.100.1.0 0.0.0.255 area 0
R2(config-router)#
*Mar  1 00:52:10.023: %OSPF-5-ADJCHG: Process 1, Nbr 9.9.9.9 on FastEthernet0/0 from LOADING to FULL, Loading Done

Lets quickly add all of the subnets on R2's loopback interfaces and check the connectivity between R2 and R1 after.

R2(config-router)#network 10.0.4.0 0.0.0.255 area 2
R2(config-router)#network 10.0.5.0 0.0.0.255 area 2
R2(config-router)#network 10.0.6.0 0.0.0.255 area 2

Now for the moment of truth, let's check if R2 can reach any of the loopback network on R1....

R2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms
R2#ping 10.0.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/15/36 ms
R2#ping 10.0.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/24 ms

Success all worked! Let's take a look at the routing table on both R1 and R2. show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
.....
O IA    10.0.6.1/32 [110/11] via 10.100.1.2, 00:10:02, FastEthernet0/1
O IA    10.0.5.1/32 [110/11] via 10.100.1.2, 00:10:02, FastEthernet0/1
O IA    10.0.4.1/32 [110/11] via 10.100.1.2, 00:10:11, FastEthernet0/1
.....
R2# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O IA    10.0.3.1/32 [110/11] via 10.100.1.1, 00:11:34, FastEthernet0/0
O IA    10.0.2.1/32 [110/11] via 10.100.1.1, 00:11:34, FastEthernet0/0
O IA    10.0.0.1/32 [110/11] via 10.100.1.1, 00:11:34, FastEthernet0/0
......

I trimmed the extraneous routes, but as you can see in the first example R1 learned about the 10.0.6.0, 10.0.5.0, and 10.0.6.0 subnets from 10.100.1.2 which is the IP address of R2's fa0/1 interface. Likewise R2 knows about the 10.0.0.0, 10.0.2.0, and 10.0.3.0 from the IP 10.100.1.1 which is R1's fa0/0 interface.

You can what is being advertised by using this command show ip protocol.

R1#show ip protocol
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 9.9.9.9
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    10.0.0.0 0.0.0.255 area 1
    10.0.2.0 0.0.0.255 area 1
    10.0.3.0 0.0.0.255 area 1
    10.100.0.0 0.0.0.255 area 0
    10.100.1.0 0.0.0.255 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    8.8.8.8              110      00:14:55
  Distance: (default is 110)

Let's continue on and configure R3:

R3(config)#router ospf 1
R3(config-router)#router-id 7.7.7.7
R3(config-router)#network 10.100.0.0 0.0.0.255 area 0
R3(config-router)#network 10.100.2.0 0.0.0.255 area 0
R3(config-router)#network 10.0.7.0 0.0.0.255 area 3
R3(config-router)#network 10.0.8.0 0.0.0.255 area 3
R3(config-router)#network 10.0.9.0 0.0.0.255 area 3

Once R3 is fully configured, check the routes and what it's advertising to it's neighbors. Also try to ping a loopback on R1 and R2.

Now for the REAL test! I'll demonstrate the self healing capabilities of OSPF and why it's so widely used. For this scenario we'll pretend that there was some catastrophic disaster  cutting the link between R1 and R3.

Now depending on how long you set the Dead Timer you will eventually see a message like this.

*Mar  1 02:46:19.123: %OSPF-5-ADJCHG: Process 1, Nbr 7.7.7.7 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

This means that the update timer has expired and the route is now stale.  My dead timer on R1 is set for 40 secs. If no Hello message is received within 40 secs OSPF recalculates the route to R3. In this case the best route is now through R2. To see the Hello and Dead intervals use this command show ip ospf int <INTERFACE> | include intervals

R1#show ip ospf int fa0/0 | include intervals
 Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

For a brief 40 secs you will not be able to ping any IP's in R3. After the 40 secs lets check the routes on R1.

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
..........
O IA    10.0.9.1/32 [110/21] via 10.100.1.2, 00:13:18, FastEthernet0/1
O IA    10.0.8.1/32 [110/21] via 10.100.1.2, 00:13:18, FastEthernet0/1
O IA    10.0.7.1/32 [110/21] via 10.100.1.2, 00:13:18, FastEthernet0/1
O IA    10.0.6.1/32 [110/11] via 10.100.1.2, 00:13:18, FastEthernet0/1
O IA    10.0.5.1/32 [110/11] via 10.100.1.2, 00:13:20, FastEthernet0/1
O IA    10.0.4.1/32 [110/11] via 10.100.1.2, 00:13:20, FastEthernet0/1
O       10.100.2.0/24 [110/20] via 10.100.1.2, 00:13:20, FastEthernet0/1
..........

The routes now show that if I want to reach the loopback interfaces on R3, I have to go through R2. Let reconnect R1 and R3 and check the routes again.

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
...................
O IA    10.0.9.1/32 [110/11] via 10.100.0.2, 00:00:25, FastEthernet0/0
O IA    10.0.8.1/32 [110/11] via 10.100.0.2, 00:00:25, FastEthernet0/0
O IA    10.0.7.1/32 [110/11] via 10.100.0.2, 00:00:25, FastEthernet0/0
O IA    10.0.6.1/32 [110/11] via 10.100.1.2, 00:00:25, FastEthernet0/1
O IA    10.0.5.1/32 [110/11] via 10.100.1.2, 00:00:26, FastEthernet0/1
O IA    10.0.4.1/32 [110/11] via 10.100.1.2, 00:00:26, FastEthernet0/1
...................

Success! The routes have been restored! Packets destined for R3 are going through 10.100.0.2 which is fa0/1 on R3!

Long winded, but I hope I was able to help out in setting up GNS3 and playing with OSPF.

If you've made it this far in this lengthy post, I apologize for making this drag on. And congrats on having a longer attention span than me! I try to keep my articles under 7 mins, but this was just too fun of a project to stop.

And as always, here are the configuration files from my routers.

R1:

Current configuration : 1310 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.0.2.1 255.255.255.0
!
interface Loopback2
 ip address 10.0.3.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.100.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.100.1.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 9.9.9.9
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 1
 network 10.0.2.0 0.0.0.255 area 1
 network 10.0.3.0 0.0.0.255 area 1
 network 10.100.0.0 0.0.0.255 area 0
 network 10.100.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2:

Current configuration : 1310 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 10.0.4.1 255.255.255.0
!
interface Loopback1
 ip address 10.0.5.1 255.255.255.0
!
interface Loopback2
 ip address 10.0.6.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.100.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.100.2.1 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 network 10.0.4.0 0.0.0.255 area 2
 network 10.0.5.0 0.0.0.255 area 2
 network 10.0.6.0 0.0.0.255 area 2
 network 10.100.1.0 0.0.0.255 area 0
 network 10.100.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3:

Current configuration : 1310 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 10.0.7.1 255.255.255.0
!
interface Loopback1
 ip address 10.0.8.1 255.255.255.0
!
interface Loopback2
 ip address 10.0.9.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.100.2.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 network 10.0.7.0 0.0.0.255 area 3
 network 10.0.8.0 0.0.0.255 area 3
 network 10.0.9.0 0.0.0.255 area 3
 network 10.100.0.0 0.0.0.255 area 0
 network 10.100.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
Intro to GNS3 and Layer 3 Routing (OSPF)
Share this